1. Напишите программу вычисления среднего арифметическо- го трёх целых случайных чисел, принадлежащих промежут- ку [0; 10). Предусмотрите вывод на экран случайных чисел, сгенерированных компьютером. НА ПИТОНЕ
Pascal: 1) const n = 10; var a:array [1..n] of integer; i:integer; begin randomize; for i:=1 to n do begin a[i]:=random(21)-10; write (a[i]:3); end; writeln; for i:=1 to n do begin if a[i]>0 then a[i]:=99; write (a[i]:3); end; writeln; end.
2) const n = 10; var a:array [1..n] of integer; p,s,i:longint; begin p:=1; s:=0; randomize; for i:=1 to n do begin a[i]:=random(21)-10; if a[i]>0 then p:=p*a[i] else if a[i]<0 then s:=s+a[i]; write(a[i]:3); end; writeln; writeln ('Proizvedenie: ',p); writeln ('Summa: ',s); end.
AutoHotkey — свободно рас язык для автоматизации выполнения задач в Microsoft Windows. AutoHotkey является языком программирования сценариев (скриптов), при к лёгкому назначению и переназначению горячих клавиш, включая кнопки мыши и джойстика. Скрипты представляют собой текстовые файлы, с расширением «.ahk». В комплект поставки входит утилита, позволяющая «скомпилировать» их в EXE файлы, и запускать на любом компьютере с ОС Windows, при этом в создаваемый файл могут быть включены другие файлы, извлекаемые при запуске.
AutoHotkey позволяет автоматизировать задачи пользователя Windows таким образом, какой невозможен или затруднён в других языках программирования. Кроме того, этот язык компактен, самодостаточен и работает на всех версиях Windows «прямо из коробки».
1)
const n = 10;
var a:array [1..n] of integer;
i:integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(21)-10;
write (a[i]:3);
end;
writeln;
for i:=1 to n do
begin
if a[i]>0 then a[i]:=99;
write (a[i]:3);
end;
writeln;
end.
2)
const n = 10;
var a:array [1..n] of integer;
p,s,i:longint;
begin
p:=1;
s:=0;
randomize;
for i:=1 to n do
begin
a[i]:=random(21)-10;
if a[i]>0 then p:=p*a[i] else
if a[i]<0 then s:=s+a[i];
write(a[i]:3);
end;
writeln;
writeln ('Proizvedenie: ',p);
writeln ('Summa: ',s);
end.
C++:
1)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;
int main()
{
int a[10];
srand (time(NULL));
for (int i = 0; i<10; i++)
{
a[i] = rand()%20-10;
cout <<a[i] <<" ";
if (a[i]>0)
a[i] = 99;
}
cout <<endl;
for (int i = 0; i<10; i++)
cout <<a[i] <<" ";
cout <<endl;
return 0;
}
2)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;
int main()
{
int a[10];
int p = 1,s = 0;
srand (time(NULL));
for (int i = 0; i<10; i++)
{
a[i] = rand()%20-10;
cout <<a[i] <<" ";
if (a[i]>0)
p*=a[i];
else if (a[i]<0) s+=a[i];
}
cout <<endl;
cout <<"Summa: " <<s <<endl
<<"Proizvedenie: " <<p <<endl;
return 0;
}
AutoHotkey позволяет автоматизировать задачи пользователя Windows таким образом, какой невозможен или затруднён в других языках программирования. Кроме того, этот язык компактен, самодостаточен и работает на всех версиях Windows «прямо из коробки».