В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alua070707
alua070707
28.03.2022 18:47 •  Информатика

1. напишите программу, находящую сумму трех чисел.
2. напишите программу, вычисляющую среднее арифметическое трех чисел
3. известны длины сторон прямоугольного треугольника a, b, c.
напишите программу, вычисляющую площадь этого треугольника.
4. по заданным координатам точек а и в вычислите длину отрезка ав.
5. известны координаты вершин а, в, с треугольника.
напишите программу, вычисляющую площадь этого треугольника.
6. для заданного х вычислите у по формуле
y=x' + 2,5x? - x+1​

Показать ответ
Ответ:
плвлаовг
плвлаовг
27.09.2021 11:50

Решение 1:

nominative = 1  # окончания им.падеж: гриб

generative = [2, 3, 4]  # список окончаний род.падеж: гриба

plural_generative = [5, 6, 7, 8, 9, 0]  # список окончаний род.падеж множ-го: грибов

for number in range(0, 51):  # цикл с значением от 0 до 51

   """number % 10  возвращает последнюю цифру из числа"""

   if (number % 10) == nominative:  

       print(f"{number} гриб")

   elif (number % 10) in generative:

       print(f"{number} гриба")

   elif (number % 10) in plural_generative:

       print(f"{number} грибов")

Решение 2:

nominative = 1  # окончания им.падеж: гриб

generative = [2, 3, 4]  # список окончаний род.падеж: гриба

for number in range(0, 51):  # цикл с значением от 0 до 51

   """number % 10  возвращает последнию цифру из числа"""

   if (number % 10) == nominative:

       print(f"{number} гриб")

   elif (number % 10) in generative:

       print(f"{number} гриба")

   else:

       print(f"{number} грибов")

Объяснение:

В комментариях.

0,0(0 оценок)
Ответ:
Infasotka41
Infasotka41
17.02.2020 07:58

Объяснение:

9/2=4 (1); 4/2=2 (0); 2/2=1 (0); (1); 9₁₀=1001₂

34/2=17 (0); 17/2=8 (1); 8/2=4 (0); 4/2=2 (0); 2/2=1 (0); (1); 34₁₀=100010₂

59/2=29 (1); 29/2=14 (1); 14/2=7 (0); 7/2=3 (1); 3/2=1 (1); (1); 59₁₀=111011₂

629/2=314 (1); 314/2=157 (0); 157/2=78 (1); 78/2=39 (0); 39/2=19 (1); 19/2=9 (1);

9/2=4 (1); 4/2=2 (0); 2/2=1 (0); (1); 629₁₀=1001110101₂

936/2=468 (0); 468/2=234 (0); 234/2=117 (0); 117/2=58 (1); 58/2=29 (0);

29/2=14 (1); 14/2=7 (0); 7/2=3 (1); 3/2=1 (1); (1); 936₁₀=1110101000₂

1875/2=937 (1); 937/2=468 (1); 468/2=234 (0); 234/2=117 (0); 117/2=58 (1);

58/2=29 (0); 29/2=14 (1); 14/2=7 (0); 7/2=3 (1); 3/2=1 (1); (1); 1875₁₀=11101010011₂

3913/2=1956 (1); 1956/2=978 (0); 978/2=489 (0); 489/2=244 (1); 244/2=122 (0);

122/2=61 (0); 61/2=30 (1); 30/2=15 (0); 15/2=7 (1); 7/2=3 (1); 3/2=1 (1); (1);

3913₁₀=111101001001₂

11649/2=5824 (1); 5824/2=2912 (0); 2912/2=1456 (0); 1456/2=728 (0);

728/2=364 (0); 364/2=182 (0); 182/2=91 (0); 91/2=45 (1); 45/2=22 (1);

22/2=11 (0); 11/2=5 (1); 5/2=2 (1); 2/2=1 (0); (1); 11649₁₀=10110110000001₂

39578/2=19789 (0); 19789/2=9894 (1); 9894/2=4947 (0); 4947/2=2473 (1);

2473/2=1236 (1); 1236/2=618 (0); 618/2=309 (0); 309/2=154 (1); 154/2=77 (0);

77/2=38 (1); 38/2=19 (0); 19/2=9 (1); 9/2=4 (1); 4/2=2 (0); 2/2=1 (0); (1);

39578₁₀=1001101010011010₂

53746/2=26873 (0); 26873/2=13436 (1); 13436/2=6718 (0); 6718/2=3359 (0);

3359/2=1679 (1); 1679/2=839 (1); 839/2=419 (1); 419/2=209 (1); 209/2=104 (1);

104/2=52 (0); 52/2=26 (0); 26/2=13 (0); 13/2=6 (1); 6/2=3 (0); 3/2=1 (1); (1);

53746₁₀=1101000111110010₂

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота