1. напишите программу, которая выводит значение порядкового номера этого значения. 2. напишите программу, которая подсчитывает количество элементов в массиве,равных 5. ,
1) var a:array [1..100] of integer; i,n,k:integer; begin readln(n); //количество элементов массива for i:=1 to n do read(a[i]); //ввод массива через пробел с клавиатуры writeln; readln(k); //ввод значения, номер которого будем искать for i:=1 to n do if a[i]=k then writeln(i) //поиск номера введенного элемента end. 2) var a:array [1..100] of integer; i,n,s:integer; begin s:=0; readln(n); //количество элементов массива for i:=1 to n do read(a[i]); //ввод массива через пробел с клавиатуры writeln; for i:=1 to n do if a[i]=5 then s:=s+1; //подсчёт кол-ва элементов равнх 5 writeln(s) end.
var a:array [1..100] of integer;
i,n,k:integer;
begin
readln(n); //количество элементов массива
for i:=1 to n do
read(a[i]); //ввод массива через пробел с клавиатуры
writeln;
readln(k); //ввод значения, номер которого будем искать
for i:=1 to n do
if a[i]=k then writeln(i) //поиск номера введенного элемента
end.
2)
var a:array [1..100] of integer;
i,n,s:integer;
begin
s:=0;
readln(n); //количество элементов массива
for i:=1 to n do
read(a[i]); //ввод массива через пробел с клавиатуры
writeln;
for i:=1 to n do
if a[i]=5 then s:=s+1; //подсчёт кол-ва элементов равнх 5
writeln(s)
end.