1) напишите программу, которая вводит натуральное число n и выводит первые n чётных натуральных чисел. с++ 2) напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ]. c++ 3) напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b . с++
#include <iostream>
using namespace std;
int main()
{
int n = 0;
cin >> n;
for (int i = 0; i < n; ++i) {
cout << 2 * i << endl;
}
return 0;
}
2)
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int a = 0, b = 0;
cin >> a >> b;
for (int i = a; i <= b; ++i) {
cout << pow(i, 2) << endl;
}
return 0;
}
3)
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int a = 0, b = 0, sum = 0;
cin >> a >> b;
for (int i = a; i <= b; ++i) {
sum += pow(i, 2);
}
cout << sum << endl;
return 0;
}