1. Напишите программу, которая считывает длины двух катетов в прямоугольном треугольнике и выводит его площадь. Каждое число записано в отдельной строке. 2. Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере Ввод Вывод 131 Предыдущее число 130 Следующее число 132 3. Пункт первый: надо написать программу-гороскоп, которая по некоторым простым вопросам выдаёт строго индивидуальный анализ личностных качеств. Мы будем делать это по передовым астрологическим методикам. Напишите программу, которая считывает с клавиатуры последовательно: имя, фамилию, любимое животное, знак зодиака. После этого программа выводит:
1) *mer?.doc - отбирает файлы с расширением .doc и именем (я буду называть именем всё без расширения), оканчивающимся на mer и еще какую-то букву. Будет отобрано только файл 2. 2) ?*mer?.doc - тут по сравнению с предыдущим добавляется условие, что перед mer должно быть что-то еще. Если в случае был 1 файл, то и в этом не больше одного. 3) *mer*?.doc - файлы с именем, содержащим mer, но не оканчивающимся на него и расширением .doc. Отберутся файлы 2, 3, 5 - три файла. 4) *?mer*?.doc - тут mer должно еще и не быть в начале, по сравнению с предыдущим. Будут отобраны файлы 2 и 5.
Using System; using System.Collections.Generic; using System.Linq; using System.Text.RegularExpressions;
namespace Dcoder { public class Program { public static void Main(string[] args) { Console.Write("Размер массива: "); int n = Convert.ToInt32(Console.ReadLine()); int[] arr = new int[n]; Random rand = new Random(); for (int i = 0; i < arr.Length; i++) arr[i] = rand.Next(1, 100); for (int i = 0; i < arr.Length; i++) if (arr[i] % 2 == 0) Console.WriteLine(arr[i]);
Console.WriteLine();
for (int i = 0; i < arr.Length; i++) if (arr[i] % 2 != 0) Console.WriteLine(arr[i]); Console.ReadLine(); } } }
1. primera.dat
2. primera.doc
3. merchant.doc
4. k-mer.doc
5. omerta.doc
6. Temerlan.docx
1) *mer?.doc - отбирает файлы с расширением .doc и именем (я буду называть именем всё без расширения), оканчивающимся на mer и еще какую-то букву.
Будет отобрано только файл 2.
2) ?*mer?.doc - тут по сравнению с предыдущим добавляется условие, что перед mer должно быть что-то еще. Если в случае был 1 файл, то и в этом не больше одного.
3) *mer*?.doc - файлы с именем, содержащим mer, но не оканчивающимся на него и расширением .doc. Отберутся файлы 2, 3, 5 - три файла.
4) *?mer*?.doc - тут mer должно еще и не быть в начале, по сравнению с предыдущим. Будут отобраны файлы 2 и 5.
ответ. 3.
using System.Collections.Generic;
using System.Linq;
using System.Text.RegularExpressions;
namespace Dcoder
{
public class Program
{
public static void Main(string[] args)
{
Console.Write("Размер массива: ");
int n = Convert.ToInt32(Console.ReadLine());
int[] arr = new int[n];
Random rand = new Random();
for (int i = 0; i < arr.Length; i++)
arr[i] = rand.Next(1, 100);
for (int i = 0; i < arr.Length; i++)
if (arr[i] % 2 == 0)
Console.WriteLine(arr[i]);
Console.WriteLine();
for (int i = 0; i < arr.Length; i++)
if (arr[i] % 2 != 0)
Console.WriteLine(arr[i]);
Console.ReadLine();
}
}
}