В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

1)Напишите программу, которая получает с клавиатуры
целое число и записывает в логическую переменную
значение «да» (True), если это число трёхзначное. После
этого на экран выводится ответ на во Верно ли, что
было получено трёхзначное число?».
2)Напишите программу, которая получает с клавиатуры
трёхзначное число и записывает в логическую
переменную значение «да» (True), если это число –
палиндром, то есть читается одинаково слева направо и
справа налево. После этого на экран выводится ответ на
во Верно ли, что введённое число – палиндром?»
(для этого для введенного числа надо получить значение
его перевертыша – поменять значение сотен и единиц, а
потом их сравнить).
ДЕЛАТЬ НА C++

Показать ответ
Ответ:
gloria81
gloria81
03.01.2022 20:20

Объяснение:

1. Пронумеруем разряды:

3-й разряд - 4;

2-й разряд - 1;

1-й разряд - 5;

0-й разряд - 3.

4153₈=4·8³+1·8²+5·8¹+3·8⁰

2. 4153₈=4·8³+1·8²+5·8¹+3·8⁰=2048+16+40+3=2155₁₀

3. 125/8=15 (5)

15/8=1 (7)

(1)

125₁₀=175₈

4. Пронумеруем разряды:

2-й разряд - A;

1-й разряд - 6;

0-й разряд - E;

A6E₁₆=(10)(6)(14)=10·16²+6·16¹+14·16⁰

5. A6E₁₆=10·16²+6·16¹+14·16⁰=2560+96+14=2670₁₀

6. 350/16=21 (14=E)

21/16=1 (5)

(1)

350₁₀=15E₁₆

7. 247/2=123 (1)

123/2=61 (1)

61/2=30 (1)

30/2=15 (0)

15/2=7 (1)

7/2=3 (1)

3/2=1 (1)

(1)

247₁₀=11110111₂

247/8=30 (7)

30/8=3 (6)

(3)

247₁₀=367₈

247/16=7 (15=F)

(7)

247₁₀=7F₁₆

Получившиеся числа между собой равны, так как имеют одинаковое число в десятичной системе счисления.

0,0(0 оценок)
Ответ:
ДаняКашин
ДаняКашин
22.08.2022 13:26

ЯП: С++ | можно не писать std:: , если использовать пространство имен: using namespace std;

#include <iostream>

int main() {

const int SIZE = 10;

int regim, sum, max, count;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 std::cin >> arr[i]; // вводим элементы массива

 std::cout << arr[i] << "\t"; // выводим массив в консоль

}

std::cin >> regim;

if ((regim > 0) && (regim < 4))

{

 if (regim == 1)

 {

  for (int i = 0; i < SIZE; i++)

  {

   sum += arr[i]; // или sum = sum + arr[i];

  }

  std::cout << "Сумма элементов массива = " << sum << std::endl;

 }

 else if (regim == 2)

 {

  max = arr[0];

  for (int i = 0; i < SIZE; i++)

  {

   if (max < arr[i])

    max = arr[i];

  }

  std::cout << "Максимальный элемент в массиве = " << max << std::endl;

 }

 else

 {

  for (int i = 0; i < SIZE; i++)

  {

   if (arr[i] < 0)

    count++;

  }

  std::cout << "Число отрицательных элементов в массиве = " << count << std::endl;

 }

}

else

 std::cout << "Доступен только 1-3 режим!" << std::endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота