В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
plalallalalalal
plalallalalalal
18.10.2021 13:10 •  Информатика

1. Напишите программу, которая по введенным пользователем трём сторонам треугольника должна определить является ли треугольник равносторонним, равнобедренным или вырожденным. Вычислить его площадь, вывести сообщение о том, какой треугольник был рассчитан.

Показать ответ
Ответ:
sofkabovs199
sofkabovs199
11.01.2021 10:50
Задача №1
var a:array[1..4, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 4 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов кратных 3-м и > 20 = ',k); 
end.

Задача №2
var a:array[1..5, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 5 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if i=j then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов главной диагонали = ',k); 
end.
0,0(0 оценок)
Ответ:
aslazer211124
aslazer211124
09.09.2021 08:19
Var a, b: integer;
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА 
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота