В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Prikolno2018
Prikolno2018
20.07.2022 22:19 •  Информатика

1)Напишите программу, которая переводит цифровую систему отметок в словесную. Например если пользователь ввел оценку "5", на экран выводится словесная отметка "Пятерка" 2)Напишите альтернативную программу с применением оператора if для 1-ой задачи

Показать ответ
Ответ:
05061972
05061972
21.03.2021 13:56

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

case i of  

1: writeln('Единица');  

2: writeln('Двойка');  

3: writeln('Тройка');  

4: writeln('Четверка');  

5: writeln('Пятерка');  

else writeln('Нет такой оценки');  

end;  

readln;  

end.

Альтернативная задача

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

if i = 1 then writeln('Единица')

else if i = 2 then writeln('Двойка')

else if i = 3 then writeln('Тройка')

else if i = 4 then writeln('Четверка')

else if i = 5 then writeln('Пятерка')

else writeln('Нет такой оценки');    

readln;  

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота