В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
12352858585
12352858585
22.01.2023 09:39 •  Информатика

1) Напишите программу, которая находит
минимальный и максимальный из чётных элементов
массива. Гарантируется, что все элементы массива
находятся в диапазоне [-100;100] и среди них есть
хотя бы один чётный элемент.
2)Напишите программу, которая находит
минимальный и максимальный из элементов
массива, заканчивающихся на "5". Если в массиве
нет таких элементов, нужно вывести слово "нет".

Показать ответ
Ответ:
лерчик1253
лерчик1253
06.02.2022 21:22

1)

a = [12,32,51,2,5,-10,-20,23,-23] # задаете любой массив

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 2 == 0:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 2 == 0:

       maxim = a[i]

       break

print(minim)

print(maxim)

2)

a = [12,32,51,2,1,-10,-20,21,-23]

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 10 == 5:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 10 == 5:

       maxim = a[i]

       break

if minim == 0 and maxim == 0:

   print('No')

else:

   print(minim)

   print(maxim)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота