1. Напишите программу к задаче: Дан массив С (40), заполненный трехзначными случайными числами. Найти произведение четных элементов и сумму нечетных элементов массива.
2. Напишите программу к задаче:
Дан массив А (120), заполненный трехзначными случайными числами. Найти произведение тех элементов, которые принадлежат отрезку (30,60) и сумму тех элементов, которые кратны 6.
C++Выделить код
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;
int main()
{
int N = 0;
double mult = 1.0;
srand(time(NULL));
cout << "VVedite N =";
cin >> N;
int *mas = new int[N];
for(int i = 0; i < N; i++)
{
mas[i] = rand() % N;
cout << "mas[" << i << "]= " <<mas[i] << endl;
if(mas[i] % 2 != 0)
{
mult*=mas[i];
}
}
delete []mas;
cout << endl;
cout << "MULT = " << mult << endl;
return 0;
}
Объяснение:
честно я не очень в этом шарю так что проверь )