В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ольга1718
ольга1718
12.07.2020 03:37 •  Информатика

1)Напишите программу для вычисления наименьшего из четырёх чисел для этого создана функция min4 в Python
2)Напишите программу для вычисления степени K (целое)числа а (действительное).Для этого создайте функцию stepen(a,k).
3)Дана строка из латинских букв и цифр .Напишите программу для подсчёта количества символов в этой строке.
4)Напишите программу ,зеркало отражающую заданное число .Например,123 отражается как 321.Используйте функцию.
5)Дана последовательность чисел,заканчивающихся нулем .Создайте программу,которая вычисляет сумму чисел без использования цикла.
Например,1 7 9 0=17
6)напишите функцию для преобразования заданной единицы в тоннах, килограммах и граммах в граммы. Наверху есть таблица
нужно !


1)Напишите программу для вычисления наименьшего из четырёх чисел для этого создана функция min4 в Py

Показать ответ
Ответ:
Alina2007271
Alina2007271
02.08.2022 20:29

1) Тут в смысле надо тебе интеграл найти если да, то

      

Program Pr2;
uses crt;
procedure arifm(a,b:integer;var s:real);
begin
s:=(a+b)/2;
end;
procedure proiz(var a,b,c:integer);
var i,m1,m2:integer;
begin
m1:=1;m2:=1;
for i:=1 to a do m1:=m1*i;
for i:=1 to b do m2:=m2*i;
if m1>m2 then c:=m1
else c:=m2;
end;
var a,b,c:integer;
s:real;
Begin
clrscr;
readln(a,b);
arifm(a,b,s);
writeln(s);
proiz(a,b,c);
writeln(c);
end.

 

 

2)

Program Pr1;
uses crt;
procedure arifm(var a,b:integer;s:real);
begin
s:=(a+b)/2;
writeln(s:8:3);
end;
var a,b:integer;
s:real;
Begin
clrscr;
readln(a,b);
arifm(a,b,s);
end.

 

 

0,0(0 оценок)
Ответ:
lnk88
lnk88
16.04.2023 11:02
1. Записывает введенное пользователем значение в переменную dr
2. integer
3. sqrt(число)
4. var
5. 16
6. 2
7.
function x(a,b,c:integer);
begin
x:=-b+sqr(b)-sqr(4*a*c)*a;
end;
8. 11
9. end.
10. d)
11.
var a,b,c:integer;
result:real;
begin
readln(a,b,c);
result:=(a*b*c)/3;
writeln(result:0:3);
end.
12. real
13. оператор присвоения
14. Присвоить переменной F значение 125
15. write(B); или writeln(B);
16. корень из суммы квадрата х и ста делить на разность а и b умноженной на с
17. с)
18. Нет картинки как образован массив, значит сами решите
19. d)
20. c)
21. c)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота