В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
koptevartem050
koptevartem050
23.10.2022 01:30 •  Информатика

1.Напишите программу для решения задачи с использованием линейного массива:

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру для дней, когда температура поднималась выше нуля градусов. Определите количество таких дней. Гарантируется, что за время наблюдения хотя бы в один из дней температура поднималась выше нуля градусов.

Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

Пример работы программы:

Входные данные Выходные данные

4

–5

12

–2

8 10.0

2

2.Напишите программу для решения задачи с использованием линейного массива:

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже –15 градусов, выведите YES, иначе выведите NO.

Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

Пример работы программы:

Входные данные Выходные данные

4

–5

12

–2

8 –5

NO

Показать ответ
Ответ:
siraevadiana
siraevadiana
16.04.2023 22:05
#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
    int y;
    cin>>y;
    y=y%12;
    switch (y){
           case 4:{cout<<"Mouse"; break;}
           case 5:{cout<<"Bull";break;}
           case 6:{cout<<"Tiger";break;}
           case 7:{cout<<"Rabbit";break;}
           case 8:{cout<<"Dragon";break;}
           case 9:{cout<<"Snake";break;}
           case 10:{cout<<"Horse";break;}
           case 11:{cout<<"Goat";break;}
           case 0:{cout<<"Monkey";break;}
           case 1:{cout<<"Cock";break;}
           case 2:{cout<<"Dog";break;}
           case 3:{cout<<"Pig";break;}
           }
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Ответ:
холера663
холера663
05.02.2020 12:51
1.
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32

2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт

3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16

4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит

8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота