1. Напишите программу для решения примера (по вариантам). Предусмотрите проверку деления на ноль. Все необходимые переменные пользователь вводит через консоль. Запись |пример| означает «взять по модулю», т.е. если значение получится отрицательным, необходимо сменить знак с минуса на плюс. Вариант 2. |((a2-b3 - c3*a2)*(b-c+c*(k-d/b3)) - (k/b -k/a)*c)2 - 20000|
2. Дан произвольный список, содержащий и строки и числа. Вариант 2. Выведите все нечетные элементы построчно.
3. Дан произвольный список, содержащий только числа.
Вариант 2. Выведите результат сложения всех чисел от 1 до 10.
4. Дан произвольный список, содержащий только числа. Вариант 2. Выведите минимальное число.
Ақпарат – ұғымы күнделікті өмірден бастап техникалық салада пайдаланылатын көп мағыналы ұғым. Жалпы алғанда бұл ұғым шектеу, байланыс, бақылау, форма, инструкция, білiм, мағына, құрылым, бейнелеу, сезіну тағы басқа ұғымдармен тығыз байланысты. Көп адам бұл жайлы Білім дәуірі немесе білім қоғамы тудырған Ақпарат дәуірі туралы айта бастады; ақпараттық қоғам, ақпараттық технологиялар, тіпті информатика, ақпарат ғылымы және компьютер ғылымы назарға көп түсуде, ал “ақпарат” сөзі білдіре бастаған мағыналары ұқыпсыз пайдаланылуда.
program z1;
const n=8;
var a:array [1..n] of integer;
i,m: integer;
begin
writeln ('Результаты заплыва: ');
for i:= 1 to n do
begin
write(i,'-й: ');
readln(a[i])
end;
writeln;
m:=a[i];
for i:= 1 to n do
if a[i]<m then m:=a[i];
writeln('Лучший: ',m)
end.
program z2;
const n=12;
var a:array [1..n] of integer;
i,m: integer;
begin
writeln ('Массив: ');
for i:= 1 to n do
begin
write(i,'-й элемент: ');
readln(a[i])
end;
writeln;
m:=a[i];
for i:= 1 to n do
if a[i]>m then m:=a[i];
writeln('Максимальный: ',m)
end.
Объяснение:
Сначала вводим элементы массива.
Затем предполагаем, что первый элемент наименьший (1 задача) или наибольший (2 задача). Потом сравниваем элементы массива с переменной, в которую записали первый элемент, и меняем переменную, если условие срабатывает. Выводим результат на экран.