В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
malesheva2017
malesheva2017
06.04.2021 11:53 •  Информатика

1.написать программу вывода чисел от a до b( a и b вводит пользователь) с шагом в 1. 2.вывести их произведение и сумму. программа с++. 50 .

Показать ответ
Ответ:
strekoza7
strekoza7
06.10.2020 01:51
1.
#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cout << "a = ", cin >> a;
    cout << "b = ", cin >> b;
    for (int i=a; i<=b; i++) {
    cout << i << " ";
    }
    return 0;
}

Пример:
a = 5
b = 12
5 6 7 8 9 10 11 12

2.
#include <iostream>
using namespace std;

int main()
{
    int a, b, s=0;
    long long p=1;
    cout << "a = ", cin >> a;
    cout << "b = ", cin >> b;
    for (int i=a; i<=b; i++) {
    p = p*i;
    s = s+i;
    }
    cout << "p = " << p << " s = " << s;
    return 0;
}

Пример:
a = 5
b = 12
p = 19958400 s = 68
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота