В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
velvidreamp06xqq
velvidreamp06xqq
23.02.2021 18:32 •  Информатика

1. написать программу, решающую уравнение ax=b. предусмотреть все варианты для значений a и b. 2. идет к-ая секунда суток. определить, сколько целых часов и целых минут с начала суток. на экран вывести фразу: «it is … hours … minutes». 3. вводится пятизначное число. найти сумму цифр этого числа. написать программы в паскале.

Показать ответ
Ответ:
udovika
udovika
25.05.2020 16:53

1.

 

program simple;

var a,b:integer;

begin

 writeln('daite a, b); readln(a,b);

 writeln('x = ', b/a); readln;

end;

 

2.

 

program day;

var h,hours,minutes:longint;

begin

  writeln('daite secundi'); readln(h);

  hour:= h div 3600; minutes:=h mod 36000;

  if (minutes > 60) or (minutes=60) then 

   begin

     hour:=hour+1;

     minutes:=minutes-60;

  end;

  writeln('It is 'hours' hours 'minutes' minutes');

readln;

end;

 

3.

 

program summaChisla;

var s:string; i,sum: longint; c,cod:integer;

begin

  writeln('daite nomer); readln(s);

  for i:=1 to length(s) do

   begin

      val(s[i],c,cod); sum:=sum+c;

   end;

writeln('summa :',sum); readln;

end;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота