В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
shipicinaolga36
shipicinaolga36
31.01.2023 04:14 •  Информатика

1. Написать программу на языке C++ (C#), которая вычисляет значение y при заданных x и t:

2. Написать программу на языке C++ (C#), которая вводит три числа, положительные числа возводит в квадрат, а отрицательные оставляет без изменений.
3. Написать программу на языке C++ (C#), которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел.
4. Написать программу на языке C++ (C#), которая вычисляет сумму первых N целых положительных нечетных чисел.
5. Написать программу на языке C++ (C#), которая выводит на экран таблицу значений функции y= 2x2 – 5x – 8 в диапазоне от – 4 до 4. Шаг изменения аргумента 0,5.
6. Написать программу на языке C++ (C#), которая формирует двумерный массив NxN по следующему правилу: элементы главной диагонали приравнять 1, ниже главной диагонали – 0, а выше – сумме индексов.
7. Написать программу на языке C++ (C#), которая задает двумерный числовой массив и меняет местами две заданные строки.
8. Написать программу на языке C++ (C#), которая печатает заданный текст, удалив из него все цифры и знаки «+» и «–».
9. Написать программу на языке C++ (C#), решающее квадратное уравнение ax2+bx+c=0 при заданных значениях a, b и c.
10. Написать программу на языке C++ (C#), которая выводит наименьшее из трех чисел.
11. Написать программу на языке C++ (C#), которая вычисляет значение y при заданных b, m, x:

12. Написать программу на языке C++ (C#), которая определяет, является ли заданное число степенью двойки.
13. Написать программу на языке C++ (C#), которая определяет делители для заданного числа.
14. Написать программу на языке C++ (C#), которая определяет сумму положительных чисел, кратных 4 и меньших 100.
15. Написать на языке C++ (C#) программу табулирования функции на заданном интервале с заданным шагом.

Показать ответ
Ответ:
#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
    using namespace std;
    cout << "Enter size of array: ";
    int N;
    cin >> N;
    int * ARR = new int[N];
    srand(time(0));
    int i;
    for (i = 0; i < N; ++i)
        ARR[i] = rand() % 100 + 1;

    cout << "Here is an original array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    int temp = ARR[N - 1];
    for (i = N - 1; i > 0; --i)
        ARR[i] = ARR[i - 1];
    ARR[0] = temp;

    cout << "\nHere is a new array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    return 0;
}
0,0(0 оценок)
Ответ:
olgasuponeva
olgasuponeva
15.08.2021 10:04
1)
var
    s: string[6];
    n: integer;

begin
    s := 'отлично';
    n := length(s);
    writeln(length('отлично'));
    writeln(n);
end.

Изначально выставлен тип string[6], значит если присвоить строку больше, то ее обрежет по 6 символов, вот и весь прикол
ответ 6

2) рисунок

3)var
    s, s1: string;
    n: integer;

begin
    s := 'информатика';
    s1 := copy(s, 3, 5);
    n := pos(s, s1);
    writeln('s=', s);
    writeln('s1=', s1);
    writeln('n=', n);
end.

Вывод
s=информатика
s1=форма
n=0

Все верно, в s1 не содержится s, а наоборот

Садекватным объяснением! 1) дан фрагмент программы: var s: string[6]; n: integer; begin s: ='отлично
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота