В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mrnazar228
mrnazar228
21.10.2020 20:49 •  Информатика

1. Написать программу на VBA, реализующую следующий алгоритм: Радиус шара S=4πR2

Рассчитать радиус для введенного R

2. Написать программу на VBA, реализующую следующий алгоритм:

Написать программу для расчета стоимости абонемента.

Стоимость билета 1000 рублей

При покупке 3х билетов, предоставляется скидка 10%

При покупке 4-7 билетов – скидка 20%

При покупке более 7 билетов – скидка 30%

Вводится количество билетов. Выводится общая стоимость билетов.

Протестировать программу для покупки 2х билетов, 4х билетов, 10 билетов.

Программу реализовать с оператора Case.

Написать блок-схему программы.

Показать ответ
Ответ:
Nastykaramova
Nastykaramova
26.02.2022 16:08
CLS
DIM n AS INTEGER
INPUT "Введите кол-во студентов:", n

DIM studentYearsOld(1 TO n) AS INTEGER
DIM studentName(1 TO n) AS STRING

FOR i = 1 TO n
INPUT "Введите имя студента:", studentName(i)
INPUT "Введите год рождения студента:", studentYearsOld(i)
NEXT i
PRINT
FOR i = 1 TO n
PRINT "Студент "; studentName(i)
studentYrs = 2016 - studentYearsOld(i)
IF studentYrs < 18 THEN
PRINT "Лет до права голоса:"; 18 - studentYrs
ELSEIF studentYrs >= 18 THEN
PRINT "Студент уже имеет право голоса!"
PRINT
END IF
studentYrs = 0
NEXT i

Код валидный, если допустил ошибку во время переписывания - сообщите.
0,0(0 оценок)
Ответ:
marypawgamesyt
marypawgamesyt
09.09.2020 06:54
Basic:
DIM tetradCount as INTEGER, oblojCount as INTEGER, price1 AS INTEGER, price2 AS INTEGER
CLS
INPUT "Введите кол-во тетрадей:"; tetradCount
INPUT "Введите кол-во обложек:"; oblojCount

price1 = tetradCount * 5
price2 = oblojCount * 3

PRINT "Стоимость тетрадей:"; price1
PRINT "Стоимость обложек:"; price2
PRINT "Общая стоимость:"; price1 + price2
END

C#:
Обычный класс, единственная директива препроцессора System, в методе main

int tetradCount, oblojCoubt, priceOne, priceTwo, priceSum;

Console.WriteLine("Введите кол-во тетрадей:");
tetradCount = int.Parse(Console.ReadLine());

Console.WriteLine("Введите кол-во обложек:");
oblojCount = int.Parse(Console.ReadLine());

priceOne = tetradCount * 5;
priceTwo = oblojCount * 3;
priceSum = priceOne + PriceTwo;

Console.WriteLine("Стоимость тетрадей: " + priceOne);
Console.WriteLine("Стоимость обложек: " + priceTwo);
Console.WriteLine("Общая стоимость: " + priceSum);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота