В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Shkolnikt
Shkolnikt
03.09.2021 11:00 •  Информатика

1. написать программу, которая в заданном с клавиатуры массиве из 7 целых чисел находит сумму элементов, меньших 4. 2. написать программу, которая находит произведение элементов массива натуральных чисел из 15 элементов, заданного случайным образом. 3. написать программу, которая определяет, находится ли в заданном случайным образом массиве из n натуральных чисел заданное число m (m вводятся с клавиатуры, n -константа).

Показать ответ
Ответ:
Nastya171167
Nastya171167
30.03.2022 10:40

//Обьявляем дополнительные переменные и главный массив, а также два дополнительных - они будут "половинками".

var

 a, b, c: array [1..100] of longint;

 i, min, n, j, t: longint;

begin

 //Читаем количество элементов в нашем массиве.

 readln(n);

 

 //Читаем массив.

 for i := 1 to n do read(a[i]);

 

 //Заполняем первую "половинку".

 for i := 1 to n div 2 do b[i] := a[i];

 

 //Заполняем вторую "половинку". Но раз это уже вторая "половинка" главного массива, то и

 //цикл теперь должен начинаться со второй части массива, а заканчиваться уже в его конце.

 for i := n div 2 + 1 to n do c[i - n div 2] := a[i];

 

 //Теперь отсортируем первую "половинку" методом выбора. Идея этого метода

 //основывается на том, что мы ищем минимальный среди неотсортированных элемент,

 //а затем аем его с тем, который стоит сразу после отсортированных.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if b[min] > b[j] then

       min := j;

   if min <> i then begin

     t := b[i];

     b[i] := b[min];

     b[min] := t;

   end;

 end;

 

 //Затем вторую точно также, только стоит обратить внимание на сравнения.

 //Так как надо отсортировать по убыванию, то теперь сравнение перед "swap"-ом

 //будет другим.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if c[min] < c[j] then

       min := j;

   if min <> i then begin

     t := c[i];

     c[i] := c[min];

     c[min] := t;

   end;

 end;

 

 //А теперь по очереди выводим готовые "половинки", не забывая ставить

 //пробел после вывода каждого элемента.

 for i := 1 to n div 2 do write(b[i], ' ');

 for i := 1 to n - n div 2 do write(c[i], ' ');

end.

0,0(0 оценок)
Ответ:
малака
малака
24.02.2022 10:07

ответ: 14) 12Кбайт = 12000 Байт

15) 896

16) Под блокнотом подразумевается стандартный Windows Notepad. Он как дважды два, и таким и задумывался. Предназначен для и возможно редактирования текстовых файлов(не документов, форматирование не изменяется), например .txt, .xml, .html и тд.

MSO Word предназначен для создания редактирования текстовых документов (не текстовых файлов) предназначеных в первую очередь для людьми. Потому очень много уделяется внимания форматированию текста, можно добавлять всякие рисунки, таблички и прочее.

Можно редактировать и текстовые файлы, но это не удобно.

Объяснение: 14) 1Кбайт = 1000 Байт

15) На каждый символ отводится по 2 байта а там 56 символов. 2*56= 112 байт. 1 Байт = 8 Бит

16) Тут объяснять то даже нечего.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота