В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nova4ka
nova4ka
05.04.2021 08:43 •  Информатика

1) написать программу, которая определяет номера строк двумерного массива a[1..6,1..4], в которых содержится хотя бы один нулевой элемент. 2) 5. составить программу заполнения массива b[1..10] таким образом: элементы с нечетными индексами равны числу 2, а элементы с четными индексами равны числу 5.

Показать ответ
Ответ:

1)

var A: array [1..6,1..4] of integer;

i,j: integer;

begin

randomize;

for i := 1 to 6 do begin

    for j := 1 to 4 do begin

        A[i,j] := random(20) - 10;

    end;

end;

 

for i := 1 to 6 do begin

    for j := 1 to 4 do begin

        if (A[i,j] == 0) then begin

            writeln("0 v stroke ", i);

            continue;

        end;

    end;

end;

 

end.

 

2)

var B: array [1..10] of integer;

i: integer;

begin

for i := 1 to 10 do begin

    if (i mod 2 == 0) then B[i] := 5;

    else B[i] := 2;

end;

 

for i := 1 to 10 do begin

    writeln(B[i]);

end;

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота