В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
IDebil
IDebil
24.06.2020 06:17 •  Информатика

1.написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов. значения элементов массива вводятся пользователем. 2.написать программу, которая определяет наибольшее по модулю число в массиве из 10 введенных пользователем чисел.

Показать ответ
Ответ:
roma1918
roma1918
08.10.2020 15:05
1.
var
mas: array[0..10] of Integer ;
i,min,j: Integer;

begin
min:=0;
writeln('Введите числа:');
for i := 1 to 10 do begin

ReadLn(mas[i]);
if (mas[i] <0)
then j:=mas[i];
if j then min:=j;
end;
WriteLn('Минимальное отрицательное число:',min);

end.

2.
var
mas: array [0..10] of Integer;
i, max, j: Integer;

begin
writeln('Введите числа:');
for i := 1 to 10 do
begin
ReadLn(mas[i]);
if abs(mas[i - 1]) < abs(mas[i]) then
max := mas[i] ;
end;
WriteLn('Наибольшее по модулю число:', max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота