В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Глебочек
Глебочек
16.04.2020 09:51 •  Информатика

1) Написать программу, которая будет выводить на экран значения переменной 208,5 (или любое другое название) то количество раз, которое показывает датчик температуры. Сделать нужно в tinkercad написать код

Показать ответ
Ответ:
zemdy926
zemdy926
23.04.2020 06:42

Решение

Объяснение:

1. Создать 2 переменные, сделать проверку через if Если a>b то writeln(a+b) else writeln(a*b) После этого writeln("ЗАДАЧА РЕШЕНА")

2.Создать переменную n(Сколько лет дракону) и h(Голова) Так же сделать проверку через if сколько ему лет Если >100 то n*3 Если <100 То (100*3)+((n-100)*2) и записать в переменную h

Что бы получить глаза достаточно h*2 (если у дракона 2 глаза)

3.Создать 2 переменные, сделать проверку через if допустим если a<b writeln(a) else (b)

4.Создать переменную в которую пользователь будет вводить число,

После этого надо его делить на 4 и округлять в меньшую сторону

Если число будет 1 - Зима Если 2 - Весна 3 - Лето 4-Зима

5. -

6. Создаем 2 переменные a,b - Записываем в них длины сторон после умножаем a*b

7.Создаем переменную скорости и расстояния - Потом Расстояние делим на скорость 600/120 И получаем время в полете

8.-

0,0(0 оценок)
Ответ:
AirinMandarin
AirinMandarin
07.09.2020 18:09
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
const
  n=5;
type
  Matrix=array[1..n,1..n] of integer;

procedure DummySchool(var a:Matrix);
begin
  Writeln('Ввод элементов матрицы');
  for var i:=1 to n do begin
    Write(n,' элементов строки ',i,': ');
    for var j:=1 to n do Read(a[i,j]);
    end;
  Writeln('Сформирована матрица ',n,'x',n);
  for var i:=1 to n do begin
    for var j:=1 to n do Write(a[i,j]:5);
    Writeln
    end
end;

begin
  var B:Matrix;
  DummySchool(B);
  var sn:=0;
  var sp:=0;
  for var i:=1 to n do
    for var j:=1 to n do
      if B[i,j]<0 then sn+=B[i,j]
      else
        if B[i,j]>0 then sp+=B[i,j];
  Writeln('Сумма отрицательных ',sn);
  Writeln('Сумма положительных ',sp)
end.

Тестовое решение:
Ввод элементов матрицы
5 элементов строки 1: 6 23 -5 13 9
5 элементов строки 2: 42 0 -38 16 37
5 элементов строки 3: -5 -18 3 11 8
5 элементов строки 4: 9 13 -11 0 3
5 элементов строки 5: 19 -17 0 15 5
Сформирована матрица 5x5
    6   23   -5   13    9
   42    0  -38   16   37
   -5  -18    3   11    8
    9   13  -11    0    3
   19  -17    0   15    5
Сумма отрицательных -94
Сумма положительных 232
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота