В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
007sergey
007sergey
05.06.2021 17:46 •  Информатика

1. Написать программу для проведения операций над матрицами (сложение, умножение на число, умножение матриц, транспонирование, возведение матрицы в степень). 2. Ввод матрицы можно осуществлять как с клавиатуры, так и случайные числа (выбирается пользователем)
3. Размерность матрицы вводится пользователем в начале
4. Выбор операции также производится пользователем
5. Каждая строка кода должна быть прокомментирована (коротко) #comment
6. Вывод должен быть форматированным и аккуратно оформлен
7. Программы должны быть у всех разные.
8. Проверка всех возможных исключений (ввод букв вместо цифр, неверные размерности матриц и т.д.)

Этапы программы:

выбор операции (выбирает пользователь)

ввод размерности (строка приглашения)

выбор генерации матрицы (случайными числами или пользователем)

заполнение

вывод результата операции (в аккуратном виде)
Без использования любых библиотек

Показать ответ
Ответ:
DianaHreseva
DianaHreseva
01.09.2022 12:55

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n, m;

   cin >> n >> m;

   vector<vector<int> > t(m, vector<int> (n));

   for (int i = 0; i < m; ++i){

         for (int j = 0; j < n; ++j){

             t[i][j] = i * n + j;

         }

      }

   for (int i = 0; i < n; ++i){

       for (int j = 0; j < m; ++j){

           cout << t[j][i] << " ";

       }

       cout << endl;

   }

   return 0;

}

Объяснение:

просто нужно заполнить массив . _.

0,0(0 оценок)
Ответ:
nicgames
nicgames
03.09.2021 12:17

1:

s = 'Это некоторое предложение'

a = ord('а')

chars = [rrchr(i) for i in range(a,a+34) if not rrchr(i) in s and i != a+32]

print(chars)

2:

parallel = [('имя1','имя2','имя3','имя4'),('имя1','имя2','имя5'),('имя2','имя4')]

names = ['имя1','имя2','имя3','имя4','имя5','имя6']

presence = []

for name in names:

 counter = 0

 for klass in parallel:

   for person in klass:

     if person == name:

       counter += 1

       break

 presence.append((name,counter))

for name in presence:

 print(name[0],'-',

       'встречаются во всех классах данной параллели' if name[1] == len(parallel)

       else 'есть только в некоторых классах' if name[1] != 0

       else 'не встречаются ни в одном классе')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота