В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vladrake
vladrake
30.10.2022 09:28 •  Информатика

1)Написать пргравмму( программный код) подсчёта количество символов в слове.
2) Написать программу (программный код) определяющую, какая из двух фамилий длиннее. Фамилии имеют разную длину.​

Показать ответ
Ответ:
Maskimilian771
Maskimilian771
23.08.2020 19:29

Не знаю на каком языке надо было, но сделал на языке Pascal

1.

var s:string;

k,i:integer;

begin

 readln(s);

 k := length(s);

 writeln(k);

end.

2.

var a,b:string;

i:integer;

begin

 writeln('Введите первую фамилию');

 readln(a);

 writeln('Введите вторую фамилию');

 readln(b);

 i:=length(a)-length(b);

 if i>0 then

   writeln('Первая фамилия длиннее')

 else writeln('Вторая фамилия длиннее')

end.

еще как вариант второго номера:

var a,b:string;

i:integer;

begin

 writeln('Введите первую фамилию');

 readln(a);

 writeln('Введите вторую фамилию');

 readln(b);

 i:=length(a)-length(b);

 if i>0 then

   writeln('Фамилия ', a, ' длиннее фамилии ', b)

 else writeln('Фамилия ', b, ' длиннее фамилии ', a)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота