1. Линейная структура построения программы подразумевает: a. Неоднократное повторение отдельных частей программы; b. Последовательное выполнение всех элементов программы; c. Выполнение лишь нескольких, удовлетворяющих заданному условию частей программы; d. Верного ответа нет. 2. Раздел VAR служит: a. Для описания используемых переменных; b. Для описания величин; c. Для описания выражений; d. Верного ответа нет. 3. Правильная строковая запись выражения a. x-х***3/absx + sin (x); b. x-x*x*x/abs(x) +sin (x); c. x-x^3/abs (x) +sin (x); d. Верного ответа нет. 4. Раздел операторов начинается служебным словом: a. VAR; b. INTEGER; c. BEGIN; d. Верного ответа нет. 5. Математическое выражение х2-7х+6 можно записать: 6. Вывод данных на экран осуществляется с оператора: a. WRITE, WRITELN; b. READ, READLN; c. PROGRAM; d. Верного ответа нет. 7. Тип переменных REAL это: a. целочисленный тип; b. логический тип; c. вещественный тип; d. верного ответа нет. 8. Установите соответствие между служебными словами и названиями разделов программы: 5 a. Var b. Program c. Uses d. Begin …end 1. Раздел операторов 2. Раздел заголовка программы 3. Раздел описания переменных 9. Раздел описания библиотечных модулейКакая структура программы верная: a. program MyProg; begin Writeln (‘Привет’); end. b. begin program MyFirst; X:=Y+195; end. 10. Операции div и mod используются для переменных типа: a. char; b. integer; c. string; d. real. 11. Вывод строки «Добрый день!» на экран: a. readln (‘Добрый день!’); b. var (‘Добрый день!’); c. writeln (‘Добрый день!’); d. program (‘Добрый день!’). 12. Оператор нахождения остатка от деления двух чисел: a. div; b. writeln; c. mod; d. crt. 13. Где перечисляются все переменные, используемые в программе? a. В заголовке программы после слова Program; b. После служебного слова uses; c. В разделе описания переменных – после слова var; d. В теле программы, между служебными словами begin и end. 14. Выберите оператор присваивания: a. Real; b. Read; c. := d. Writeln. 15. Выберите правильный вид записи оператора: a. Writeln (‘Введите числа через пробел’); b. Real (‘a,b’); c. Writeln (Сумма двух чисел равна, Summa); d. 3*sqr(x):=A; 16. Как выглядит форматный вывод данных: a. Write (n); b. Write (‘n’); c. Write (n:5:3); d. Write (‘n=’, n). 17. Какой оператор определяет равенство двух значений? a. = b. == c. =: d. := 18. В алфавит языка Pascal не входит служебное слово: a. THEN; b. BEGIN; c. END; d. STEP; 19. Каким служебным словом описываются символьные переменные: a. INTEGER; b. REAL; c. CHAR; d. BOOLEAN; 20. Сколько операций выполняется при вычислении выражения (a-2/5)-2/5*(a+2/5) a. 5 b. 6 c. 7 d. 8.
НА PYTHON
1. Написать программу, которая будет считывать с клавиатуры числа до тех пор, пока не будет введен 0. После ввода нуля программа должна выдать на экран количество чисел, которое было введено, без учета нуля.
2. Написать программу, которая будет считывать с клавиатуры числа до тех пор, пока не будет введен 0. После ввода нуля программа должна выдать на экран количество троек, которое было введено.
3. Написать программу, которая будет считывать с клавиатуры числа до тех пор, пока не будет введен 0. После ввода нуля программа должна выдать на экран количество четных и нечетных чисел, которое было введено, без учета нуля.
4. Написать программу, которая будет считывать с клавиатуры числа до тех пор, пока не будет введен 0. После ввода нуля программа должна выдать на экран сумму отдельно четных и отдельно нечетных чисел, которые были введены, без учета нуля.
5. Написать программу, которая будет просить пользователя ввести с клавиатуры любое число. После этого, программа просит вводить числа до тех пор, пока сумма чисел, которые введены, не будет больше или равна первому числу пользователя. Пример работы программы приведен ниже.
6. Написать программу, которая будет просить пользователя ввести число с клавиатуры и выводить на экран все числа, на которые делится это число. Пример работы программы приведен ниже. В программе должен быть использован цикл while и не более одного раза команда if.
Число пи — математическая постоянная, равная отношению длины окружности к её диаметру. Обозначается буквой греческого алфавита «π».
3,1415926535 8979323846 2643383279 5028841971 6939937510 5820974944 5923078164 0628620899 8628034825 3421170679 8214808651 3282306647 0938446095 5058223172 5359408128 4811174502 8410270193 8521105559 6446229489 5493038196 4428810975 6659334461 2847564823 3786783165 2712019091 4564856692 3460348610 4543266482 1339360726 0249141273 7245870066 0631558817 4881520920 9628292540 9171536436 7892590360 0113305305 4882046652 1384146951 9415116094 3305727036 5759591953 0921861173 8193261179 3105118548 0744623799 6274956735 1885752724 8912279381 8301194912 9833673362 4406566430 8602139494 6395224737 1907021798 6094370277 0539217176 2931767523 8467481846 7669405132 0005681271 4526356082 7785771342 7577896091 7363717872 1468440901 2249534301 4654958537 1050792279 6892589235 4201995611 2129021960 8640344181 5981362977 4771309960 5187072113 4999999837 2978049951 0597317328 1609631859 5024459455 3469083026 4252230825 3344685035 2619311881 7101000313 7838752886 5875332083 8142061717 7669147303 5982534904 2875546873 1159562863 8823537875 9375195778 1857780532 1712268066 1300192787 6611195909 2164201989...
Объяснение: