В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ирочка300
Ирочка300
01.02.2022 02:22 •  Информатика

№1. дан массив из 30-ти элементов. каждый элемент может принимать целочисленные значения от -100 до 100. напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. дан массив из 40 элементов. каждый элемент может принимать целочисленные значения от 0 до 200. напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Показать ответ
Ответ:
annmslna2044
annmslna2044
12.06.2020 02:55

var a:array[1..40] of integer;

i, j, cou, coumax, amax: integer;

begin

   coumax:=0;

   for i:=1 to 40 do

      readln(a[i]);

   for i:=1 to 40 do begin

      cou:=0;

      for j:=1 to 40 do

         if(a[i]=a[j]) then inc(cou);

      if(cou>coumax) then begin

         coumax:=cou;

         amax:=a[i];

      end;

   writeln(amax, ' is the most repeated value');

end.

 

var a1, temp, cou, i, sum:integer;

begin

   read(a1);

   if (a1>=0) then cou:=1 else cou:=0;

   if (cou>0) then sum:=a1 else sum:=0;

   for i:=2 to 40 do begin

      read(temp);

      if (temp>0) and (temp mod a1=0) then begin

         inc(cou);

         inc(sum,temp);

      end;

   end;

   writeln(sum/cou)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота