В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ROMAGTTV900
ROMAGTTV900
04.07.2021 07:57 •  Информатика

1. дан фрагмент программы, определяющий количество неотрицательных элементов массива a[1..10]. восстановите пропущенное условие.
k: =10;
i: =1;
while i< =10 do
begin
if then k: =k – 1;
i: =i+1
end;
write (p)
a[i]> 0
a[i]> 0
a[i]< =0
a[i]< 0
2.задан одномерный массив а, содержащий n элементов. укажите, что будет определено в результате работы следующего фрагмента программы:
k: =0;
for i: =1 to n do
if a[i]> =0 then k: =k+1
количество положительных элементов массива
максимальный элемент массива
количество неотрицательных элементов массива
сумма положительных элементов массива

3. что такое массив?
это структурированный тип данных, состоящий из элементов разных типов
это совокупность данных, объединенных под одним именем
это структурированный тип данных, состоящий из элементов одного типа, по номеру и объединенных под одним именем
это простой тип данных, состоящий из одного элемента
4. задан одномерный массив а, содержащий n элементов. значения всех элементов массива различны. укажите, что будет определено в результате работы следующего фрагмента программы:
m: =a[1];
for i: =1 to n do
if a[i]< =a[1] then m: =a[i]
значение максимального элемента массива
индекс максимального элемента массива
значение минимального элемента массива
индекс минимального элемента массива
5. дан одномерный массив.
-125 200 10 0 43 11

чему равно значение элемента массива с индексом 3.
6. выберите правильное описание массива а, состоящего из нескольких переменных вещественного типа
a : array [1..25] of real
a : array [1..25] of integer
a : [1..25] of real
a : array [1..25] of byte
7. var a: array [1..59] of integer;
при выполнении этого оператора в памяти компьютера будет выделено … ячеек целого типа.
50
58
59
60
8. каким ввода элементов массива а лучше воспользоваться, если значения элементов массива равны своим удвоенным индексам?
с оператора присваивания по формуле a[i]: =2* a[i]
с оператора присваивания по формуле a[i]: =2*i
с оператора присваивания случайными числами
любым из предложенных вариантов
9. выберите правильные варианты вывода элементов массива на печать в столбик. (2 ответа)
for i: =1 to n do writeln (a[i])
for i: =1 to n do writeln (`a`, i, `=`, a[i])
for i: =1 to n do write (a[i], ` ` )
for i: =1 to n do writeln ( i, `]=`)
10. какой оператор необходимо вставить вместо многоточия в следующий фрагмент программы на языке паскаль, чтобы верно решалась нахождения суммы элементов массива а, содержащего n элементов?

for i: =1 to n do s: =s+a[i]
s: =a[1]
s: =a[n]
s: =1
s: =0

Показать ответ
Ответ:
Iamboss11111
Iamboss11111
12.06.2021 11:34
Program A_1;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i;
  until i=n;
  writeln('Сумма чисел от 1 до ',n,' равна ',sum);
end.

Program B_2;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i*i;
  until i=n;
  writeln('Сумма квадратов чисел от 1 до ',n,' равна ',sum);
end.

Program V_3;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    if (i mod 2 = 0) then sum:=sum+i;
  until i=n;
  writeln('Сумма чётных чисел в диапазоне от 1 до ',n,' равна ',sum);
end.

Program G_4;
uses crt;
Var
  i,n,sum: integer;
begin
  i:=9;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i;
  until i=99;
  writeln('Сумма всех двузначных чисел равна ',sum);
end.
0,0(0 оценок)
Ответ:
jdjsjsjsj
jdjsjsjsj
19.05.2021 00:48
Вопрос 11. Информационной моделью, которая имеет табличную структуру, является:
ответ 2. расписание авиарейсов;

Вопрос 12. Информационной моделью, которая имеет сетевую структуру, является:
ответ 3. модель компьютерной сети Интернет;

Вопрос 13. Натурное моделирование - это:
ответ 4. моделирование, при котором модель имеет визуальную схожесть с объектом-оригиналом

Вопрос 14. Информационной моделью объекта нельзя считать:
ответ 3. другой объект, не отражающий существенных признаков и свойств объекта-оригинала;

Вопрос 15. Математическая модель объекта - это:
ответ 1. совокупность записанных на языке математики формул, отражающих свойства объекта;

Вопрос 16. В отношениях «объект-модель» находятся
ответ 2. болт - чертеж болта;

Вопрос 17. К числу документов, представляющих собой информационную модель управления государством, можно отнести:
ответ 1. Конституцию РФ;

Вопрос 18. К информационным моделям, описывающим организацию учебного процесса в школе, можно отнести:
ответ 4. расписание уроков.

Вопрос 19. Отметить истинное высказывание:
ответ 4. чтение справочной литературы - это поиск информации.

Вопрос 20. Рисунки, карты, чертежи, диаграммы, схемы, графики представляют собой:
ответ 3. графические информационные модели;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота