В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Здраствуйте решить задачу на Python Аве, Цезарь ️
На вход программе подается строка текста на английском языке, в которой нужно зашифровать все слова. Каждое слово строки следует зашифровать с шифра Цезаря (циклического сдвига на длину этого слова). Строчные буквы при этом остаются строчными, а прописные – прописными.

Формат входных данных
На вход программе подается строка текста на английском языке.

Формат выходных данных
Программа должна вывести зашифрованный текст в соответствии с условием задачи.

Примечание. Символы, не являющиеся английскими буквами, не изменяются.

Sample Input 1:

Day, mice. "Year" is a mistake!
Sample Output 1:

Gdb, qmgi. "Ciev" ku b tpzahrl!
Sample Input 2:

my name is Python!
Sample Output 2:

oa reqi ku Veznut!

Показать ответ
Ответ:
ssdjpiffi
ssdjpiffi
26.12.2022 12:08

Для создания пароля используются и прописные и строчные буквы латинского алфавита, поэтому общее количество символов используемых для пароля N=26+26= 52.

Определим количество бит i на 1 символ из формулы  N=2^i

Число должно быть целое и достаточное для кодирования 52 символов.   2⁵ < 52 < 2⁶  

получается на 1 символ приходится 6 бит

Для хранения 7 символов пароля необходимо: 6*7=42 бита.

По условию для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт.

Округляем информационный объем пароля в большую сторону до целого числа кратного 8, переводим в байты и прибавляем 12 байт дополнительных сведений:

48/8+12= 18 байт

Получаем, что 18 байт выделено для хранения информации об одном пользователе.

Тогда количество пользователей в системе:

2*1024/18=113,77

ответ: 113 пользователей.

Объяснение:

0,0(0 оценок)
Ответ:
voloseikotatian
voloseikotatian
28.04.2023 08:53

var

 a,c1,c2,s1,s2:integer;

begin

 readln(a);

 if a=0 then  

   begin

     writeln('Error');

     exit;

   end;

 s2:=-30000; c2:=30000;

 s1:=-30000; c1:=30000;

 repeat

   if (a>s1) or (a>s2) then

     if s1>s2 then

       s2:=a  

     else

       s1:=a;

   if (a<c1) or (a<c2) then

     if c1>c2 then

       c1:=a

     else

       c2:=a;

   readln(a);

 until a=0;

 writeln('max: ',s1+s2);

 writeln('min: ',c1+c2);

end.

Если моё решение вам, пометьте его лучшим !

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота