В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
daniiltpgatov6
daniiltpgatov6
11.12.2021 18:00 •  Информатика

В Python 3.
«A»: Напишите программу, которая заполняет квадратную
матрицу случайными числами в интервале [10,99], и
находит максимальный и минимальный элементы в
матрице и их индексы.
Пример:
Матрица А:
12 14 67 45
32 87 45 63
69 45 14 11
40 12 35 15
Максимальный элемент A[2,2]=87
Минимальный элемент A[3,4]=11
Очень нужно

Показать ответ
Ответ:
nastia311
nastia311
29.01.2023 11:22
Сказано было сформировать массивы с имененем А и В. Заполняем их целыми числами, так что и  объявить массивы можно как целые. Но это мелочи, не обязательные.
var    
a, b: array[1..20]of integer;  
  i, s,n: integer;    
begin  
   writeln('Массив А:');
   randomize;     
   for i := 1 to 20 do  
     begin     
     a[i] := random(100) - 50;
     write(a[i],' ');     
     if (a[i] > 0) and (i mod 2 = 0) then
        begin
        n:=n+1;   
        b[n]:= a[i];        
        s := s + b[n] * b[n];  
        end;
     end;
   writeln();
   writeln('Массив В:');
   for i:=1 to n do write(b[n]);
   writeln;
   writeln('S = ', s);
end.
0,0(0 оценок)
Ответ:
ALEXAND2033
ALEXAND2033
21.10.2022 17:21
Const
  destinations = 'СЗЮВСЗЮВСЗЮВ';    {Предварительно сформированная строка ориентаций}
var
  C : char;
  N1, N2, Position : integer;
begin
  write('Исходная ориентация локатора: ');
  readln(C);
  write('Первая команда поворота: ');
  readln(N1);
  write('Вторая команда поворота: ');
  readln(N2);
  Position := Pos(C, destinations) + 4;   {Устанавливаем позицию на положение заданного направления}
  Position := Position + N1; {Направление после первого поворота (Определяется destinations[Pos])}
  Position := Position + N2; {Направление после второго поворота (Определяется destinations[Pos])}
  writeln('Конечная ориентация: ', destinations[Position]);
end.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота