В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
djhvh235
djhvh235
08.09.2022 22:59 •  Информатика

PYTHON Рейтинг бакалавра заочного отделения при поступлении в магистратуру определяется средним по диплому, умноженным на коэффициент стажа работы по специальности, который равен: нет стажа – 1, меньше 2 лет – 13, от 2 до 5 лет – 16. Составить программу расчета рейтинга при заданном среднем диплома (от 3 до 5) и вывести сообщение о приеме в магистратуру при проходном 45.

Показать ответ
Ответ:
gtufifk
gtufifk
15.10.2020 14:25

Python 3.7:

point = float(input('Введите ваш средний : '))

while not(3 <= point <= 5):

   point = float(input('Введите ваш средний : '))

work_time = float(input('Введите ваш стаж работы по специальности: '))

if work_time == 0:

   k = 1

elif work_time < 2:

   k = 13

else:

   k = 16

print('Вы приняты в магистратуру!' if k*point >= 45 else 'Вы не приняты в магистратуру.')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота