В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ксения654654
Ксения654654
02.06.2020 20:18 •  Информатика

Напишите программу в Python В детском садике n детей играют в следующую игру. Перед ними гора из m
кубиков, первый ребёнок вынимает из кучи 1 кубик, каждый последующий
ребёнок — в два раза больше предыдущего и так по кругу. Если число кубиков, которые нужно вынуть, превышает 25, из него вычитается 25 и отсчёт
идёт от уменьшенного числа, например, вместо 32 кубиков будет вынуто 7,
затем 14 и т. д. Проигравшим считается тот, кто не смог вытащить нужное
число кубиков (в куче осталось недостаточно). Определите проигравшего.

Показать ответ
Ответ:
niki189
niki189
14.03.2021 03:17

ответ:A№1

mass = [int(input()) for i in range(5)]

for i in mass:

   if i % 3 == 0 and i % 10 == 8:

       print(i, end=' ')

№2

from random import randint

mass = [randint(100, 999) for i in range(100, 1000)]

for i in range(len(mass) - 1):

   for j in range(i + 1, len(mass)):

       if mass[i] % 100 > mass[j] % 100:

           mass[i], mass[j] = mass[j], mass[i]

print(mass)

№3

from random import randint

mass = [randint(0, 1000) for i in range(1000)]

for i in range(len(mass) - 1):

   if mass[i] == mass[-1]:

       print(i, end=' ')

B№1

mass = [int(input()) for i in range(5)]

k = 0

for i in mass:

   if str(i)[0] == '8':

       k += 1

print(k)

№2

from random import randint

mass = [randint(100, 999) for i in range(100, 1000)]

for i in range(len(mass) - 1):

   for j in range(i + 1, len(mass)):

       if sum(map(int, str(mass[j]))) < sum(map(int, str(mass[i]))):

           mass[i], mass[j] = mass[j], mass[i]

print(mass)

№3

from random import randint

mass = [randint(0, 1000) for i in range(1000)]

print(mass)

k = mx = 0

for i in range(1, len(mass)):

   if mass[i] * mass[k] > mx:

       mx = mass[i] * mass[k]

       max_i, max_k = i, k

   k += 1

print(max_k, max_i)

Объяснение:

не знаю сколько чисел должно быть в массиве в интервале от 0, 1000

если надо изменить, то поменять в range(1000) на нужное кол-во чисел

0,0(0 оценок)
Ответ:
Лисичка6661
Лисичка6661
10.01.2020 03:03

ответ: ок я програмист со стажем

Объяснение:

user = "імя"

action = "школа"

 

log_message = 'Пользователь {} зашел на сайт и выполнил действие: {}'.format(

   user,

   action

)

 

print(log_message)

# Пользователь імя зашел на сайт и выполнил действие: школа

from dataclasses import dataclass

 

@dataclass

class Armor:

   armor: float

   description: str

   level: int = 1

   

   def power(self) -> float:

       return self.armor * self.level

   

armor = Armor(5.2, "Common armor.", 2)

armor.power()

# 10.4

 

print(armor)

# Armor(armor=5.2, description='Common armor.', level=2)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота