В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Mihailkim2018
Mihailkim2018
17.06.2020 18:16 •  Информатика

Напишите программу которая считает произведение цифр введенного натурального числа..

Показать ответ
Ответ:
VERONIKA75498768783
VERONIKA75498768783
25.08.2020 12:59
Var
  n, p: integer;

begin
  write('Число: ');
  readln(n);
  p := 1;
  while n > 0 do
  begin
    p := p * (n mod 10);
    n := n div 10
  end;
  writeln('Произведение цифр = ', p);
end.

Тест №1
Число: 54321
Произведение цифр = 120

Тест №2
Число: 54320
Произведение цифр = 0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота