В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу в паскаль. дан массив целых чисел. найти количество пар соседних элементов, в которых одно число четное, а другое отрицательное. выведите также сформированный массив и все искомые пары соседних элементов.

Показать ответ
Ответ:
aRikKira05
aRikKira05
03.10.2020 18:05
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var b:=a.Pairwise; b.Println;
  Writeln('Найдено пар: ',
    b.Where(x->(x[0]<0) and x[1].IsEven or
      (x[1]<0) and x[0].IsEven).Count)
end.

Тестовое решение
n= 10
-37 -71 -71 -65 73 -66 -33 -85 62 -92
(-37,-71) (-71,-71) (-71,-65) (-65,73) (73,-66) (-66,-33) (-33,-85) (-85,62) (62,-92)
Найдено пар: 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота